Main Menu

Fixing The LightWave3D Discovery Mode Licensing Issue On Windows 8 and 10

For users of LightWave3D who have run into Discovery Mode suddenly and then continuously coming up even after having LW run normally for ages, this fix is for you.

Alternatively, you can automate this using a single click any time you need to fix the problem.
Thanks to Jim Oblak for the example below.

1. Create a text file called: FixFirewallLW.bat
2. Edit it with notepad++ or notepad or your favorite text editor and place the following instructions into it.

echo off
Start “” “C:\Program Files\NewTek\LightWave_2020.0.2\bin\configure.exe” “unset”
timeout /t 3 /nobreak > NUL
Start “” “C:\Program Files\NewTek\LightWave_2020.0.2\bin\configure.exe” “set”

3. Save the file making sure that it only has a .bat extension rather that .bat.txt or .txt at the end.
4. Run that file in administrator mode by right clicking it it and choosing “Run in Administrator Mode ” in the window that comes up.
5. Reboot and get back to work. Sometimes a reboot may not be required after the fix rules is set for the firewall. Sometimes before running this
it’s a good idea to reboot your machine first, execute these commands via the .bat file and fire up layout or modeler and see if it works.

Have fun!






11 Comments to Fixing The LightWave3D Discovery Mode Licensing Issue On Windows 8 and 10

  1. AnimeJoex says:

    kat, can I tell you that I friggin LOVE you without it getting weird? LOL 😉

  2. AnimeJoex says:

    Works for LightWave 2018 too. My Yoga 2 Pro is a VERY VERY stubborn machine and keeps downloading Windows updates that undo whatever I do to get LightWave to run in full mode. Right after you exit Modeler and Layout and restart them, they launch right back in Discovery Mode. Thankfully there doesn’t appear to be any limits on how many times we can perform Kat’s trick to get out of Discovery mode, so I’ll just have to keep doing it whenever I’m about to launch Modeler and Layout on this machine.

  3. AnimeJoex says:

    I had pretty much given up all hope on ever getting LightWave to run properly on my Yoga 2 Pro, so I’m very grateful to finally have some way of getting it to run on there as I had been dealing with that issue ever since I got the Yoga 2 Pro a few years ago.

    It’s weird because LightWave 9.6 – 2015.3. all run perfectly fine on my Windows 7 desktop PC, and they run fine on the older laptops here that were upgraded to Windows 10, but it absolutely refuses to work on the one laptop I commute to work with. At one point I was carrying two laptops in my backpack to work just so I could use LightWave, lol

  4. J D says:

    Thanks mucho! This worked perfectly 🙂

  5. Fernando Martins says:

    OMG!!! You just saved my sanity!
    Usually I just install Lightwave once and then copy the Lightwave folder between computers (desktop to laptop, so I can work on-the-go). This always worked, but this time it didn’t. I was wondering why when I realized that this laptop was the first I had running Windows 10.
    I spent 2 days bouncing my head over this, even running Layout as administrator and compatibility mode and everything else I could remember. I was even downloading the installation package in order to install it from scratch (I’m on vacation, with a connection that throw’s me back to 1998 because it seems like I’m using an US Robotics 28800, so it says it would take around 7 hours). Then I bumped into your video, and it was a life saver. (even if with the “unset” parameter I didn’t get any list, then it worked with the “set” parameter).
    Thank you so much. This should be in the FAQ somewhere.

    • kat says:

      No problem! This one has been a pain for some time since Win 8.0 shipped. I finally made a video on it after hitting it on one of my workstations and said.. “no more!” 🙂

  6. raymondtrace says:

    a pipe appears where a new line should begin…

    |echo off
    |Start “” “C:\Program Files\NewTek\LightWave_2020.0.2\bin\configure.exe” “unset”
    |timeout /t 3 /nobreak > NUL
    |Start “” “C:\Program Files\NewTek\LightWave_2020.0.2\bin\configure.exe” “set”

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.